[PyQt] Can't install eric 19 in debian 9.6

Detlev Offenbach detlev at die-offenbachs.de
Fri Jan 11 09:56:33 GMT 2019


it seems that QSci and Qt are not compatible. QScintilla wants Qt version 5.11 
but your Qt seems to be different. Maybe you have two different variants/
versions of Qt installed (one via the package management and one via the PyQt5 


Am Donnerstag, 10. Januar 2019, 23:24:59 CET schrieb Starglider Developer:
> I get this error:
> Shall 'QScintilla' be installed using pip? (Y/n) Y
> Requirement already satisfied: QScintilla in
> /usr/local/lib/python3.5/dist-packages
> Requirement already satisfied: PyQt5>=5.10.1 in
> /usr/local/lib/python3.5/dist-packages (from QScintilla)
> Requirement already satisfied: sip<4.20,>=4.19.4 in
> /usr/local/lib/python3.5/dist-packages (from PyQt5>=5.10.1->QScintilla)
> Sorry, please install QScintilla2 and
> its PyQt5/PyQt4 wrapper.
> Error: /usr/local/lib/python3.5/dist-packages/PyQt5/Qt/lib/libQt5Core.so.5:
> version `Qt_5.11' not found (required by
> /usr/local/lib/python3.5/dist-packages/PyQt5/Qsci.so)

Detlev Offenbach
detlev at die-offenbachs.de

More information about the PyQt mailing list