[PyQt] Can't install eric 19 in debian 9.6

Guðjón Guðjónsson gudjon.i.gudjonsson at gmail.com
Sat Jan 12 07:19:50 GMT 2019


On Fri, Jan 11, 2019 at 10:57 AM Detlev Offenbach
<detlev at die-offenbachs.de> wrote:
> it seems that QSci and Qt are not compatible. QScintilla wants Qt version 5.11
> but your Qt seems to be different. Maybe you have two different variants/
> versions of Qt installed (one via the package management and one via the PyQt5
> wheels).
> Am Donnerstag, 10. Januar 2019, 23:24:59 CET schrieb Starglider Developer:
> > I get this error:
> > Shall 'QScintilla' be installed using pip? (Y/n) Y
> > Requirement already satisfied: QScintilla in
> > /usr/local/lib/python3.5/dist-packages
> > Requirement already satisfied: PyQt5>=5.10.1 in
> > /usr/local/lib/python3.5/dist-packages (from QScintilla)
> > Requirement already satisfied: sip<4.20,>=4.19.4 in
> > /usr/local/lib/python3.5/dist-packages (from PyQt5>=5.10.1->QScintilla)
> > Sorry, please install QScintilla2 and
> > its PyQt5/PyQt4 wrapper.
> > Error: /usr/local/lib/python3.5/dist-packages/PyQt5/Qt/lib/libQt5Core.so.5:
> > version `Qt_5.11' not found (required by
> > /usr/local/lib/python3.5/dist-packages/PyQt5/Qsci.so)
I agree with Detlev.

The QScintilla version in Debian is 2.9.3. I don't know if that
version is compatible with eric 19 but I suggest that you
stick to the Debian packages as much as possible.
If you want to go outside of the package system you need to remove the
conflicting Debian packages.

You can also upgrade to Debian Unstable (I run that myself) or we
could backport eric to stable.

Hope that helps.


More information about the PyQt mailing list