PyQt6 6.0.1 upgrade issue.

Detlev Offenbach detlev at
Mon Feb 8 17:05:20 GMT 2021


after the initial report on the list I checked my installation as well 
and it failed as described. Somehow the Qt/lib folder was not installed 
during the upgrade from PyQt 6.0.0 to 6.0.1. I downloaded the PyQt6-Qt 
wheel and simply copied the lib folder into the Qt directory. Voila, the 
issue is gone.


Am 08.02.21 um 16:24 schrieb RoadrunnerWMC:
> I had the same issue, and PyQt6-Qt was automatically installed with
> the update as far as I could tell. What fixed it for me was completely
> uninstalling PyQt6 ("pip3 uninstall PyQt6"), manually deleting all of
> the residual "PyQt"-related folders from the site-packages directory,
> and then reinstalling it.
> On Mon, Feb 8, 2021 at 8:10 AM Ludovic Bellière
> <belliere.ludovic at> wrote:
>> Ensure you have PyQt6-Qt installed and upgraded to 6.0.1 too.
>>> pip freeze | grep PyQt
>> On Mon, 8 Feb 2021 07:57:27 +0100
>> José Antonio Fernández Fernández <aullasistemas at> wrote:
>>> Hi. when I run the command "sudo -H pip3 install --upgrade PyQt6 ==
>>> 6.0.1" (I have previously updated PyQt6-sip). and I try to import
>>> QtCore in the console, it returns the following error:
>>>>>> from PyQt6 import QtCore
>>> Traceback (most recent call last):
>>>    File "<stdin>", line 1, in <module>
>>> ImportError: cannot open shared object file: No such
>>> file or directory.
>>> With PyQt6 6.0.0 it works fine. regards.

Detlev Offenbach
detlev at

More information about the PyQt mailing list