PyQt6 v6.2.0 Snapshots Available

Detlev Offenbach detlev at
Sat Jul 17 12:02:47 BST 2021


I tried it again. This time I got an issue installing from your server. 
Using the command

~/environments/pyqt6env/bin/python3 -m pip install --index-url --pre --upgrade 
--force-reinstall PyQt6 PyQt6-Qt6 PyQt6-Charts PyQt6-Charts-Qt6 

pip issues an error message and aborts.

INFO: pip is looking at multiple versions of pyqt6 to determine which 
version is compatible with other requirements. This could take a while.
ERROR: Cannot install PyQt6 and pyqt6-charts==6.2.0.dev2107131250 
because these package versions have conflicting dependencies.

The conflict is caused by:
     The user requested PyQt6
     pyqt6-charts 6.2.0.dev2107131250 depends on PyQt6>=6.2.0

To fix this you could try to:
1. loosen the range of package versions you've specified
2. remove package versions to allow pip attempt to solve the dependency 

ERROR: ResolutionImpossible: for help visit

What did I do wrong? I am using pip version 21.1.3 (note that pip has a 
new dependency resolver as of version 20.3).


Am 17.07.21 um 11:31 schrieb Phil Thompson:
> On 15/07/2021 17:04, Detlev Offenbach wrote:
>> Hi Phil,
>> I tried these snapshots and have a few issues.
>> 1. PyQt6-Charts doesn't install because pip cannot resolve the 
>> dependency.
> The '--pre' flag doesn't seem to influence dependencies (which may be 
> a pip bug). Install PyQt6-Charts (and PyQt6-Charts-Qt6) with '--no-deps'.
>> 2. When I try to start eric I get an error message about not being
>> able to find the xcb platform plugin. With PyQt 6.1.x everything is
>> fine.
> I've updated the Linux PyQt6-Qt6 wheel. The version number is the same 
> so use '--force-reinstall'.
> Phil

Detlev Offenbach
detlev at

More information about the PyQt mailing list